您好,欢迎来到站长目录(28sn.com)!


MPLS专题03_H3C LDP动态建立LSP实验

来源:网络整理 浏览:264次 时间:2020-10-30

实验说明

实验名称

MPLS专题03_H3C LDP动态建立LSP实验

组网说明

在SW-A和SW-C之间使用LDP动态建立LSP,使192.168.1.0/24和192.168.2.0/24这两个网段中互访的报文能够通过MPLS进行传输

实验难度

★★★

发布平台

微信公众号‘IT后院’

文件下载

公众号回复‘51CTO.LDP’可下载本实验源文件

网络拓扑图

clipboard.png

步骤一:IP网络互联配置

SW-A

interface GigabitEthernet1/0/1

port link-mode route

ip address 10.1.1.1 255.255.255.252

#

vlan 10

interface Vlan-interface10

ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/10

port link-mode bridge

port access vlan 10

#

interface LoopBack0

ip address 1.1.1.1 255.255.255.255

SW-B

interface GigabitEthernet1/0/1

port link-mode route

ip address 10.1.1.2 255.255.255.252

#

interface GigabitEthernet1/0/2

port link-mode route

ip address 20.1.1.1 255.255.255.252

#

interface LoopBack0

ip address 2.1.1.1 255.255.255.255

SW-C

interface GigabitEthernet1/0/2

port link-mode route

ip address 20.1.1.2 255.255.255.252

#

vlan 10

interface Vlan-interface10

ip address 192.168.2.1 255.255.255.0

#

interface GigabitEthernet1/0/10

port link-mode bridge

port access vlan 10

#

interface LoopBack0

ip address 3.1.1.1 255.255.255.255

【步骤一配置解释】

 使网络设备之间直连可以互通,并在SW-A 和 SW-C 上创建业务网关。

clipboard.png


步骤二:OSPF 配置

SW-A

 ospf 1 router-id 1.1.1.1

area 0.0.0.0

network 1.1.1.1 0.0.0.0

network 10.1.1.0 0.0.0.3

network 192.168.1.0 0.0.0.255

SW-B

 ospf 1 router-id 2.1.1.1

area 0.0.0.0

network 2.1.1.1 0.0.0.0

network 10.1.1.0 0.0.0.3

network 20.1.1.0 0.0.0.3

SW-C

 ospf 1 router-id 3.1.1.1

area 0.0.0.0

network 3.1.1.1 0.0.0.0

network 20.1.1.0 0.0.0.3

network 192.168.2.0 0.0.0.255

【步骤二配置解释】

配置OSPF 动态路由协议,发布自身路由。因为LDP要根据路由信息动态分配标签,因此,利用LDP动态建立LSP时,需要配置路由协议,使得各路由器之间路由可达。

clipboard.png


步骤三:MPLS LDP 配置

SW-A

mpls lsr-id 1.1.1.1

mpls ldp

lsp-trigger all

#

interface GigabitEthernet1/0/1

mpls enable

mpls ldp enable

SW-B

mpls lsr-id 2.1.1.1

mpls ldp

lsp-trigger all

#

interface GigabitEthernet1/0/1

mpls enable

mpls ldp enable

interface GigabitEthernet1/0/2

mpls enable

mpls ldp enable

SW-C

mpls lsr-id 3.1.1.1

mpls ldp

lsp-trigger all

#

interface GigabitEthernet1/0/2

mpls enable

mpls ldp enable

【步骤三配置解释】

 系统视图和接口视图下使能MPLS和MPLS LDP功能,并配置LSP的触发建立策略为所有静态路由和IGP路由项都触发LDP建立LSP。

3.png


实验结果验证

如下图,SW-A可以通过MPLS 访问SW-C下的主机192.168.2.2

4.png


 【如果在实验中有什么疑问,请关注微信公众号“IT后院”给我留言,我会抽空回答你的问题】

---END---


推荐站点

  • 我爱发烧音乐我爱发烧音乐

    我爱发烧音乐囊括了从流行音乐到古典音乐多个类型的音乐作品,专栏推荐最新的音乐,提供音乐排名榜单!可供免费线上收听音乐,歌曲流畅,音效极佳! 网站提供的钢琴以及二胡专栏,可供收听者,陶冶情操,改善心情,是难得的轻音乐典藏!

    www.520fs.com
  • 世纪音乐网世纪音乐网

    世纪音乐网是专业的在线音乐试听MP3下载网站。歌曲总计30余万首,收录了网上最新歌曲和流行音乐,DJ舞曲,非主流音乐,经典老歌,劲舞团歌曲,搞笑歌曲,儿童歌曲,英文歌曲等。是您上网听歌的最佳网站。

    www.ssjj.com
  • 怒江大峡谷网怒江大峡谷网

    怒江大峡谷网内容包括:新闻、要闻、怒江报、视频、文化、民俗、人文、音乐、政务、公告、政策等地方信息。

    www.nujiang.cn
  • 杭州网杭州网

      杭州网是杭州地区唯一的新闻门户网站,由中共杭州市委宣传部、杭州日报报业集团和杭州广播电视集团共同组建的杭州网络传媒有限公司运营。

    www.hangzhou.com.cn
  • 深圳在线深圳在线

      深圳在线 www.szol.net是深圳本地最大、最早的地方生活资讯网站之一,网站名“深圳在线www.szol.net”由南方报业传媒集团编辑委员会总编辑、南方日报社总编辑、南方都市报总编辑、南方书画院名誉院长王春芙亲笔题名,深圳在线www.szol.net团队与深圳热线www.szonline.net、奥一网www.oeeee.com都源于全国最早成立于1996年的知名网络公司——深圳万用网。

    www.szol.net

鄂公网安备 42062502000001号